Announcement

Collapse
No announcement yet.

Brown spots

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Brown spots

    I have 2 of these plants (4 weeks on Oct 23rd), growing RDWC under a 125W CFL. I will change to 250W HPS for flowering. (It's still too warm here to control the temperature of the tent for HPS just yet). I use GH Flora Series and the pH (average 6.0) and EC (average 0.5, slowing increasing) mixed using RO water, are well within range, so I don't think it is a nutrient deficiency. Nutrient temperature is now controlled by a water cooler and kept at 20 to 21 degC. It was running warmer up to 2 days ago - 20 to 23 degC. The brown spots are on the lower and middle leaves and only one plant is affected. Any suggestions on what this might be?
    Sweet Nurse, auto, feminized. 4 weeks old

  • #2
    Hi pequod. Welcome.
    Do you use calmag at all? I had a similar thing going on and cal mag fixed it.
    If not, check out come of the rust spot fungi. But try calmag first.

    Comment


    • #3
      Thanks for the reply Saturnalia. I did realise I had forgotten the cal-mag as I am using RO water, so I added some. Seems to have stopped the problem, but the spots remain although plants and roots look healthy. Although there are new yellow "squareish" marks on 1 upper leaf. I think it is yellow leaf spot (leaf septoria) comparing with pictures. I sprayed with a general purpose fungicide yesterday. Hoping it will halt this. I also changed to my 250W HPS a few days ago but I don't think this has any detrimental effect. EC is 1.2 and pH is steady.

      Comment


      • #4
        How are you getting on with this now?

        Comment

        Working...
        X